好库网首页 | 我的好库
好库网 好库网社区
IT社区 » 其它板块 » 手机开发(Android/iPhone/WP8) » Xcode ARC需要什么版本的环境支持
回复 发帖

查看:1865    回复:0 Xcode ARC需要什么版本的环境支持
访问iphone的空间
发表于 2012/9/24 11:20:31
1楼

Mac OS X v10.6 和 v10.7 (64位应用) 的Xcode 4.2以上版本支持ARC,iOS 4 和 iOS 5 下ARC都能工作,但Weak不支持Mac OS X v10.6 和 iOS 4,所以要想在iOS 4下运行用ARC的程序,只能用strong。

 

1)支持ARC的开发环境:Mac OS X v10.6 和 v10.7 (64位应用) 的Xcode 4.2以上版本

2)支持ARC的运行环境:

  2.1 支持weak:iOS 5 或 Mac OS X v10.7以上

  2.2 不支持weak: iOS 4 或 Mac OS X v10.6

您需要登录后才可以回帖 登录 | 注册
回复 发帖